[Emacs]Wanderlustのインストール

  • このエントリーをはてなブックマークに追加
LINEで送る
Pocket

 

環境

OS:Debian Wheezy amd64

Emacs:23.4.1

Wanderlust:2.15.9

インストール

DebianでWanderlustの開発版をインストールします.

apt-get install wl-beta

SSL (Secure Socket Layer) の利用

‘/usr/share/doc/wl-beta/README.Debian’を読むと,

sslを利用するためにはgnutls-binとca-certificates

パッケージをインストールする必要があります.

‘/etc/emacs/site-start.d/65wl-beta.el’に

ssl-program-name変数にopensslのかわりにgnutls-cliが

ssl-program-arguments変数にverify certificatesが

設定されています.

以下が該当箇所です.

(setq ssl-program-name “gnutls-cli”)
(setq ssl-program-arguments
‘(“–port” service
“–x509cafile” “/etc/ssl/certs/ca-certificates.crt”
host))

gnutls-binとca-certificatesパッケージのインストール

すでにインストールされていましたが,コマンドは以下のとうりです.

apt-get install gnutls-bin ca-certificates

Infoファイル

Top > Start Me Up > Installまで読了.

LINEで送る
Pocket

  • このエントリーをはてなブックマークに追加

SNSでもご購読できます。