パッケージシステムpackage.elの設定(2018年版)

  • このエントリーをはてなブックマークに追加

1 インストール環境とソフトウェアのバージョン

文書作成時のOS,ソフトウェアのバージョンは以下のとうりです。

OS:Debian buster(testing)
Emacs:25.2.2
package.el:1.1.0

2 設定

package.elはEmacs24から同梱されているので設定のみ書きます。

(require 'package)

;;; Add package-archives
(add-to-list 'package-archives '("melpa" . "https://melpa.org/packages/") t)
(add-to-list 'package-archives '("melpa-stable" . "https://stable.melpa.org/packages/") t)

;; Initialize
(package-initialize)

3 参考リンク

melpa.elをインストールしたりシンボリックリンクを作成する必要がなくなってます。

使用方法のみ参考にしてください。

パッケージシステムの設定 | Emacsのelispインストール・設定・使い方

  • このエントリーをはてなブックマークに追加

SNSでもご購読できます。