[Emacs]Emacs24.1を新機能付きでコンパイルする

LINEで送る
Pocket

はじめに

必要なライブラリを調べるために一つ一つやっていますが,めんどうな人は最後のまとめ のコマンドを入力するだけでいいです.

gtk3

以下のコマンドにより必要なライブラリをインストールします.

$ sudo apt-get install libgtk-3-dev

その後,

$ ./configure –with-x-toolkit=gtk3
$ make
$ sudo make install

でインストールできます.

GnuTLS

以下のコマンドにより必要なライブラリをインストールします.

$ sudo apt-get install libgnutls-dev

その後,

$ ./configure
$ make
$ sudo make install

でインストールできます.

SELinux

以下のコマンドにより必要なライブラリをインストールします.

$ sudo apt-get install libselinux1-dev

その後,

$ ./configure
$ make
$ sudo make install

でインストールできます.

ImageMagick

以下のコマンドにより必要なライブラリをインストールします.

$ sudo apt-get install libmagick++-dev

その後,

$ ./configure
$ make
$ sudo make install

でインストールできます.

libxml2

特にライブラリの追加インストールはありません.

$ ./configure
$ make
$ sudo make install

でインストールできます.

‘–with-wide-int’オプション

バッファサイズの制限が512MiBから2GiBになるので有効にします.

まとめ

前回の記事とあわせて,入力するコマンドは以下のようになります.

$ sudo apt-get install libgtk2-dev libXpm-dev libjpeg-dev libgif-dev libtiff4-dev libncurses5-dev libgtk-3-dev libgnutls-dev libselinux1-dev libmagick++-dev
$ ./configure –with-x-toolkit=gtk3 –with-wide-int
$ make
$ sudo make install

LINEで送る
Pocket

SNSでもご購読できます。